Older browsers can no longer access TIAA-CREF accounts

Consistent with precautions being taken by a number of website hosts, access is now blocked to TIAA-CREF sites for anyone using older versions of Internet Explorer, Mozilla Firefox, or Safari. Users should immediately update to one of the following browsers instead:
  • Microsoft Internet Explorer 8.0, and 9.0
  • Mozilla Firefox 7.0 and later
  • Safari 3.0 and later.
The site block is a precaution based on a security vulnerability recently identified with any older browser using Security Socket Layer (SSL) version 3, which includes the older browsers named above.  The newer versions of each of these browsers are updated with later security protections to facilitate safe computing.  Please be assured that no client data is at risk. However, those who are using unsupported versions of an Internet browser will receive an error message indicating “The secure connection cannot be established,” and the user will not be able to proceed with accessing secure web resources.
At TIAA-CREF, customer data security is a top priority. We use a combination of technology, people and processes to protect our customers and their data. For those interested in additional information about protecting their online information, please visit our Security Center available via the highlighted link or at the bottom of our main home page at www.tiaa.org.